Comment comparer deux colonnes pour trouver les valeurs manquantes (valeur unique) dans Excel


Supposons que nous ayons deux listes, la liste A contient tous les étudiants, la liste B ne contient que les étudiants qui ont réussi l’examen. Ainsi, la liste A est plus longue que la liste B, et les étudiants de la liste B sont tous inclus dans la liste A.

Si nous voulons savoir quel étudiant a échoué à l’examen, nous pouvons cependant comparer les deux listes et trouver la valeur manquante pour confirmer la liste de nom. En fait, dans notre travail, nous rencontrons souvent les situations dont nous avons besoin pour comparer deux listes et trouver les valeurs manquantes. Dans ce tutoriel, nous vous aiderons à trouver les valeurs manquantes de deux manières:

  • La première est par la fonction de mise en forme conditionnelle dans Excel
  • La seconde est en utilisant une formule avec la fonction RECHERCHEV

Comparer deux colonnes Excel pour rechercher la valeur manquante à l’aide de mise en forme conditionnelle

  1. Préparez deux colonnes. La colonne A contient tous les étudiants. La liste B contient que les étudiants qui ont réussi l’examen

Comparer deux colonnes Excel
2. Sélectionner la colonne A et la colonne B.

Sélectionner les deux colonnes à comparer

3. Cliquer sur Accueil dans le ruban, cliquez sur Mise en forme conditionnelle dans le groupe Styles.

Mise en forme conditionnelle excel

3. Dans la liste déroulante Mise en forme conditionnelle, sélectionnez Règles de mise en surbrillance des cellules -> Valeurs en double.

Règles de mise en surbrillance des cellules excel

4. Dans la boîte de dialogue valeurs en double, sélectionnez Unique dans la liste déroulante. Conservez la valeur par défaut dans la liste déroulante qui contient la couleur de remplissage. Cliquez ensuite sur OK.

remplire en rouge les valeurs unique en excel

6. Vérifier que les valeurs uniques sont correctement marquées en rouge clair.

À lire aussi:  Comment réparer l'erreur de sauvegarder votre fichier Excel? Voici la solution

résultat comparaison deux colonnes excel

Cette méthode peut être utilisée pour rechercher des valeurs uniques à partir de deux colonnes Excel.

Comparer deux colonnes Excel pour trouver les valeurs manquantes à l’aide d’une formule

1. Insérer une nouvelle colonne entre la colonne A et la colonne B

trouver les valeurs manquantes entre deux colonnes excel

2. Dans B2, entrer la formule suivante:

=SIERREUR(RECHERCHEV(A2;$C$2:$C$12;1;FAUX);FAUX) La fonction RECHERCHEV peut nous aider à rechercher la valeur de correspondance dans la liste B. La fonction SIERREUR est utilisée pour vérifier si la valeur de correspondance existe ou non.

3. Faites glisser la poignée de remplissage vers le bas. Vérifiez que B2 et B7 et B10 sont remplis par VRAI.

comparer 2 colonnes excel

Ainsi, dans la colonne A, DAVID et LEROY et ROUX sont des étudiants qui ont échoué à l’examen.

Laisser un commentaire